Vendor Discourse
Affected product Discourse
Affected versions stable <= 3.0.2; beta <= 3.1.0.beta3; tests-passed <= 3.1.0.beta3
Vulnerability type CWE-79: Cross-Site Scripting
Description This vulnerability is not exploitable on the default install of Discourse. A custom feature must be enabled for it to work at all, and the attacker’s payload must pass the CSP to be executed. However, if an attacker succeeds in embedding Javascript that does pass the CSP, it could result in session hijacking for any users that view the attacker’s post.
Status fixed in stable >= 3.0.3; beta <= 3.1.0.beta4; tests-passed <= 3.1.0.beta4
Reporter So Sakaguchi, GMO Cybersecurity by Ierae, Inc.